WordPress Spryng Payments WooCommerce 1.6.7 Cross Site Scripting

WordPress Spryng Payments WooCommerce plugin version 1.6.7 suffers from a cross site scripting vulnerability.

Details Security News
Publication Date: 09/05/2019
Danger: Low

Vulnerable versions: Spryng Payments for WooCommerce version 1.6.0, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6, 1.6.7

Description:
Cross Site Scripting in Spryng Payments for WooCommerce for WordPress

Manufacturer URL: //profiles.wordpress.org/spryng

Decision: No way to fix the vulnerability currently exists.

References: //www.cybersecurity-help.cz/vdb/SB2019090502

Spryng payments Woocommerce is prone to a reflected cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied data.
An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.
To exploit this issue following steps:
The XSS reflected because the value url is not filter correctly.